Thursday, November 25, 2010

CodeSign error: code signing is required for product type 'Application' in SDK 'iOS 4.2'

After update sdk4.2 , I am getting this error..

I found no way to solve.. so creating new project with existing files..

Edited: No Issues after creating new project with existing source.  :)

Edited on Feb 1, 2011

Got the same error today


This time I found the issue and fixed..

in xCode menu  Project -> Edit Active Target "App"

the profile was selected for "Code Signing Identity" instead of "Any iOS".
So deleted the value of "Code Signing Identity" and select profile for "Any iOS" . The following image is the correct one.








2013 , March 11
Got this issue again:

CodeSign error: code signing is required for product type 'Application' in SDK 'iOS 6.1'




15 comments:

  1. I'm experiencing the same thing. New projects are fine but old ones - Grrrrr....

    ReplyDelete
  2. create new project and add old files.. :)

    ReplyDelete
  3. I got the same error again today [BEROR]CodeSign error: code signing is required for product type 'Application' in SDK 'iOS 4.2'
    Today I found the reason for it and fixed. I have edited above post to add this.

    ReplyDelete
  4. You save my life man. Thanks you very much. It works perfect

    ReplyDelete
  5. Thanks a lot! Your post was really useful for me. I was looking into the Project setting first, and never thought to look into the app config...

    ReplyDelete
  6. very helpful post. I always had this problem and didn't figure the error. Thanks.

    ReplyDelete
  7. Thanks you were a life saver......

    ReplyDelete
  8. good job, thanks.

    ReplyDelete
  9. great first time developer and i get out of trouble straight away because of this

    Cheers
    Tony

    ReplyDelete
  10. wonderful! that fixed it for me
    Cheers,
    CPL

    ReplyDelete